帮助中心

立即注册 咨询客服

当前位置:首页 > 帮助中心> 在基于Arch的Linux发行版中使用Pacman命令的入门教程

在基于Arch的Linux发行版中使用Pacman命令的入门教程

发布时间:2020年04月20日 08:17:53    来源: A5互联

在这篇新手指南中,我将为您讲解一些管理基于Arch的系统所必须掌握的pacmand命令的基本用法。

Arch Linux用户应该知道的基本pacman命令

一、使用pacman安装软件包

和其他软件包管理器一样,pacman可以将软件包列表与软件资源库同步,让用户通过解决所有需要的依赖关系,通过简单的命令就可以下载和安装软件包。

您可以通过以下方式使用pacman命令安装单个软件包或多个软件包:

pacman -S _package_name1_ _package_name2_ ...

安装套件

其中-S代表同步化。它的意思是,Pacman首先同步。

pacman数据库根据安装软件包的原因将其分为两类:

explicitly-installed:通用pacman -S或-U命令安装的软件包

dependencies:隐藏式安装的软件包,因为另一个显式安装的软件包需要使用。

二、删除已安装的软件包

要删除单个软件包,请保留所有依赖项的安装:

pacman -R package_name_

要删除任何其他已安装软件包都不需要的软件包及其依赖项,请执行以下操作:

pacman -Rs _package_name_

删除不再需要的依赖项。例如,删除了需要依赖的程序包。

pacman -Qdtq | pacman -Rs -

三、升级软件包

Pacman提供了一种更新Arch Linux的简便方法。您只需一个命令即可更新所有已安装的软件包。这可能需要一段时间,具体取决于系统的最新状态。

以下命令同步存储库数据库并更新系统的软件包,但不包括已配置的存储库中没有的“本地”软件包:

pacman -Syu

S代表同步

y用于刷新(本地)

u用于系统更新

基本上是说同步到中央存储库(主软件包数据库),刷新主软件包数据库的本地副本,然后执行系统更新(通过更新所有具有较新版本的软件包)。

注意:

如果您在升级之前是Arch Linux用户,建议您访问Arch Linux主页以查看最新消息以获取非常规更新。如果需要人工干预,会有相应的新闻帖子。或者,您可以订阅RSS feed或arch-announce邮件列表。

另外,请注意在升级基本软件(例如内核,xorg,systemd或glibc)之前,先查看相应的论坛,以解决任何已报告的问题。

滚动发布发行版(例如Arch和Manjaro)不支持部分升级。这意味着当将新的库版本推送到存储库时,需要针对库重建存储库中的所有软件包。例如,如果两个程序包依赖于同一个库,则仅升级一个程序包可能会破坏依赖于该库的旧版本的另一个程序包。

四、使用pacman搜索软件包

Pacman使用-Q标志来查询本地软件包数据库,使用-S标志来查询同步数据库,以及使用-F标志来查询文件数据库。

Pacman可以在数据库中搜索软件包名称和描述中的软件包:

pacman -Ss _string1_ _string2_ ...

要搜索已经安装的软件包:

pacman -Qs _string1_ _string2_ ...

要在远程软件包中搜索软件包文件名:

pacman -F _string1_ _string2_ ...

要查看程序包的依赖关系树:

pactree _package_naenter code hereme_

五、清理程序包缓存

Pacman将其下载的软件包存储在/ var / cache / pacman / pkg /中,并且不会自动删除旧版本或已卸载的版本。这具有一些优点:

它允许降级软件包,而无需通过其他来源检索以前的版本。

可以轻松地直接从缓存文件夹中重新安装已卸载的软件包。

但是,有必要定期清理缓存以防止文件夹增大。

pacman-contrib软件包中提供的paccache(8)脚本默认会删除已安装和卸载的软件包的所有缓存版本(最新的3个除外):

paccache -r

Sudo Paccache R

六、清除缓存

要删除所有当前未安装的缓存软件包以及未使用的同步数据库,请执行:

pacman -Sc

要从缓存中删除所有文件,请使用两次清洁开关,这是最积极的方法,不会在缓存文件夹中保留任何内容:

pacman -Scc

安装本地或第三方软件包

安装不是来自远程存储库的“本地”软件包:

pacman -U _/path/to/package/package_name-version.pkg.tar.xz_

安装官方存储库中未包含的“远程”软件包:

pacman -U http://www.example.com/repo/example.pkg.tar.xz

七、使用pacman排除常见错误

这是使用pacman管理软件包时可能会遇到的一些常见错误。

1、提交事务失败(文件冲突)

如果看到以下错误:

error: could not prepare transaction

error: failed to commit transaction (conflicting files)

package: /path/to/file exists in filesystem

Errors occurred, no packages were upgraded.

发生这种情况是因为pacman已检测到文件冲突,不会为您覆盖文件。

解决此问题的一种安全方法是,首先检查另一个软件包是否在使用该文件(pacman -Qo / path / to / file)。如果该文件由另一个软件包拥有,请提交错误报告。如果该文件不属于另一个软件包,请重命名“存在于文件系统中”的文件,然后重新发出更新命令。如果一切顺利,则可以删除该文件。

您可以显式运行pacman -S –overwrite glob软件包来强制pacman覆盖与glob匹配的文件,而不是手动重命名并稍后删除属于该软件包的所有文件。

2、提交事务失败(无效或损坏的软件包)

在/ var / cache / pacman / pkg /中查找.part文件(部分下载的软件包),然后将其删除。这通常是由于在pacman.conf中使用自定义XferCommand引起的。

3、初始化事务失败(无法锁定数据库)

当pacman要更改软件包数据库时(例如安装软件包),它将在/var/lib/pacman/db.lck中创建一个锁定文件。这样可以防止pacman的另一个实例尝试同时更改程序包数据库。

如果在更改数据库时pacman被中断,则该过时的锁定文件可以保留。如果确定没有pacman实例在运行,请删除锁定文件。

检查进程是否持有锁定文件:

lsof /var/lib/pacman/db.lck

如果以上命令未返回任何内容,则可以删除锁定文件:

rm /var/lib/pacman/db.lck

如果使用lsof命令输出找到包含锁定文件的进程的PID,请先将其终止,然后再删除该锁定文件。